Pixel & Vertex Shader

Jun 16, 2008 at 10:26 PM
Edited Jun 16, 2008 at 10:30 PM
When i debug the X-Editor to try it, i create a new project, i add the Dynamic Sky to the scene and i set its properties, nothing appears in the editor and i got an error about pixel & vertex shaders, formerly this:

Both a valid vertex shader and pixel shader (or valid effect) must be set on the device before any draw operations may be performed.

So, what? Does XE2 needs 3.0 shaders?
I got an old & crappy Radeon 9600 PRO.
Coordinator
Jun 18, 2008 at 3:58 AM
Well, first of all, the dynamic sky relies on the Environment Parameters class. You will need one of these as well, and you will need to drag it to the corresponding section in the Dynamic sky properties.

However, this sounds like a graphics card thing, because when I try to use the more complicated parts of the engine on my semi-crappy laptop, I usually get that message. In other words, yes, you need a better graphics card.

I dont have a list of minimum specs, but from the errors I get, I would say at least the following, which I dont think that card supports:

Card must support 32 bit index buffers.
Card must support Vertex Shader Version 1.1
Card must support Pixel Shader Version 2.0b